Download

Home / Download

Information



BlendLuxCore v2.5
Supported Blender versions: 2.82 to 2.92. Will not work on 2.93+.
(Note: you can use an automatic build of the under development v2.6 if you need to use Blender v2.93)
Installation :: Readme








Windows 64bit


Mac OS 64bit


Linux 64bit




An early access version of LuxCoreRender integration with 3DS Max. More information are available here.




Windows 64bit



Standalone release v2.5








Windows 64bit


Mac OS 64bit


Linux 64bit




LuxCore API SDK release v2.5








Windows 64bit


No Mac OS release of v2.5 SDK.


Linux 64bit


Sources available here and older versions available here

Download Example Scenes